Keen 6: maphead problem

Anything related to Keen Modding.
Post Reply
User avatar
szemigi
Posts: 592
Joined: Fri Jan 23, 2009 8:06 pm
Location: Hungary
Contact:

Keen 6: maphead problem

Post by szemigi » Thu Jan 24, 2019 1:12 pm

So firstly, I copied the GAMEMAPS.CK6 and the maphead.ck6 (The Photachyon Transceiver level editor version!!!) to my Keen 6 mod's folder. Then, I used the following things in the patchfile:

"%gamemaps GAMEMAPS.CK6
%maphead maphead.ck6"


(It was tested with either modified or untouched graphics; so I used ModKeen and KeenGraph).

As a test, I ran the game in the two cases (modified with untouched graphics; either with ModKeen and KeenGraph) and I experienced that for example in Guard Post One, I activated the switch at the exit, but the goplat didn't move. Same happened in Bloogton Tower as well. I tried to edit something to fix them in TOM, but that didn't help either after that.


What did I do wrong? Did ModKeen or KeenGraph mess up something? TOM doesn't support TPT gamemap and maphead files? Maybe there are other patches that interferes something?

Answer please, as I have never encountered a problem like this before and I'm starting to be furious after suffering with it through hours!


EDIT: I haven't tested these with Keen 4 and 5, yet though.

User avatar
Fleexy
Site Admin
Posts: 490
Joined: Fri Dec 12, 2008 1:33 am
Location: Blogham Tower
Contact:

Re: Keen 6: maphead problem

Post by Fleexy » Thu Jan 24, 2019 6:29 pm

I'm pretty sure graphical changes couldn't cause this problem. Is it possible that TPT mangled the infoplane? Make sure the links are still there - TOM and Abiathar can show these graphically.

If you upload the level files I can take a look.

Post Reply