Has anyone seen these?

Request patches for Keen Dreams.
Post Reply
User avatar
MultiMania
Patch Master
Posts: 153
Joined: Mon Nov 24, 2003 3:09 am
Location: Deep in the heart of keen.
Contact:

Has anyone seen these?

Post by MultiMania » Fri Jan 14, 2005 9:04 am

Has anyone seen any of these pictures in Keen Dreams?

Image

Image

Edit: These two are used in the Select Controls" screen.
Image

Image

I haven't seen them at all, but they are stored in the graphics files.

(Thanks go to Andy for pointing me to the correct huffman dictionary, better than all the munged art I got before)

KeenRush
Patch Maker
Posts: 1988
Joined: Sun Aug 31, 2003 2:52 pm
Location: Sand Yego
Contact:

Post by KeenRush » Fri Jan 14, 2005 12:31 pm

Very nice! No, I haven't seen, at least the two in up. :) Are you working on some modkeen for this? ::drool::

User avatar
MultiMania
Patch Master
Posts: 153
Joined: Mon Nov 24, 2003 3:09 am
Location: Deep in the heart of keen.
Contact:

Post by MultiMania » Sat Jan 15, 2005 2:32 am

KeenRush wrote:Are you working on some modkeen for this?
Yes, I have the tiles, the masked tiles, the 8x8 tiles, the 8x8 masked tiles, the font and the first 64 bitmaps. I get a couple of sprites out, but the rest look really strange, as if the planes are not aligned properly. The Masked bitmaps just look horrible, and Bitmap 65 is too big or something.

szevvy
Posts: 4
Joined: Sat Jan 15, 2005 10:49 pm

KD

Post by szevvy » Sat Jan 15, 2005 10:56 pm

How are you counting your bitmaps - are the calling the first one 0 or 1? If you're counting from 0, then bitmap 65 doesn't exist, as there's only 65 bitmaps.

edit: Grab a copy of Wombat 0.4 here

It opens Keen Dreams, and you'll be able to compare your bitmap outputs and see where the bug is.

KeenRush
Patch Maker
Posts: 1988
Joined: Sun Aug 31, 2003 2:52 pm
Location: Sand Yego
Contact:

Post by KeenRush » Sun Jan 16, 2005 10:09 am

w00t, gotta try it today! :) Cheers!

User avatar
MultiMania
Patch Master
Posts: 153
Joined: Mon Nov 24, 2003 3:09 am
Location: Deep in the heart of keen.
Contact:

Post by MultiMania » Mon Jan 17, 2005 12:55 pm

It's typical, as soon as I fix it I see a post with it already done, but there is still the problem of importing, and all those missing images (anyone found the title screen?) My extracter does everything szevvy's does now.

szevvy
Posts: 4
Joined: Sat Jan 15, 2005 10:49 pm

Post by szevvy » Tue Jan 18, 2005 1:35 am

Title screen - it's the last set of tiles in the unmasked 16x16 tiles.

Also, ModKeen has the the import routines already written, you just gotta make some small adjustments and it'll work sweet.

User avatar
MultiMania
Patch Master
Posts: 153
Joined: Mon Nov 24, 2003 3:09 am
Location: Deep in the heart of keen.
Contact:

Post by MultiMania » Tue Jan 18, 2005 2:14 am

szevvy wrote:Title screen - it's the last set of tiles in the unmasked 16x16 tiles.
Nup, those are unused (as far as I can tell). I think the title screen is a compressed DeluxePaint Image in KDREAMS.CMP.

And the hard part isn't importing the graphics, its getting Keen Dreams not to crash on me while loading them!

It currently just quits saying "out of memory", but, with luck, I'll get it to work.

User avatar
adurdin
Site Founder
Posts: 546
Joined: Fri Aug 29, 2003 11:27 pm
Location: Edinburgh, Scotland
Contact:

Post by adurdin » Tue Jan 18, 2005 6:39 am

You know, of course, that the first step is getting it to import the exact same graphics...?

Post Reply