Couple K4 mod issues

Request patches for Keens 4-6.
Post Reply
Quillax
Posts: 11
Joined: Sun Mar 27, 2016 5:48 pm
Contact:

Couple K4 mod issues

Post by Quillax » Sat Dec 23, 2017 7:34 pm

I've been making a K4 levelpack and it's been quite a fun project. However though, I had a couple issues, which are listed below:

1)I made a new loading screen, but when the mod uses it, the loading screen is all black except for the top bit and some of the text. When I start the mod, some weird stuff happens (such as audio not playing and levels refusing to start). I did what the TheDraw tutorials said on KeenWiki, so I'm not sure what did I do wrong. The only solution I found so far is to not use a modified loading screen, but I'm wondering if anyone knows any other solution that keeps the modified loading screen.

2)There's a water level that has two Dopefish together in an area. Sometimes when they eat and burp together, some sprites will freeze, and then the entire game freezes shortly after. From what I've observed, it seems to happen when two Dopefish try to eat one Schoolfish. One solution to this problem seems to be removing at least one Dopefish, but that would decrease the difficultly and make it less fun, since I can't use any other hazard (game crashes if the swimming Keen touches a hazard that isn't a Dopefish unless he's in a specific level). I've seen Keen 4 and TKoK use two Dopefish in the same area without causing any other problems, so I'm hoping that means there's another solution. Here's what Abiathar's Level Inspector says about the level if it helps with anything:
Abiathar Level Inspector report for Level17
Issues were detected that may cause unexpected behavior in-game.

Warnings:
- Door has null pointer at (38, 12)
- Door has null pointer at (39, 12)
- Door has null pointer at (38, 13)
- Door has null pointer at (39, 13)

Information:
- Infoplane icon tally: 69
- Sprite memory usage score: 47
- Tile memory usage score: 113
- Animated tile type total: 7

End of report: 0 problems, 4 warnings.
Does anyone know any other possible solutions to the problems I listed above?

User avatar
Nisaba
Posts: 226
Joined: Fri Jan 01, 2016 11:15 pm
Location: patch.pat
Contact:

Re: Couple K4 mod issues

Post by Nisaba » Sun Dec 24, 2017 12:50 am

Quick question about the crash: did you modify your patch file to load the new loading screen?
Next I'd like to point your attention towards abiathars warning section. So, tell me: why are u using doors in an underwater level? Not sure, but this might cause the gamefreeze. (@Fleex?)

Quillax
Posts: 11
Joined: Sun Mar 27, 2016 5:48 pm
Contact:

Re: Couple K4 mod issues

Post by Quillax » Sun Dec 24, 2017 1:52 am

I did edit the patch file to load the new loading screen; that's when the problem happens.

The doors are only for decoration. I did remove them once, but the problem still happens. Also, it seems that the freeze actually happens when two Dopefish burp at the same time in the same spot.

User avatar
Nisaba
Posts: 226
Joined: Fri Jan 01, 2016 11:15 pm
Location: patch.pat
Contact:

Re: Couple K4 mod issues

Post by Nisaba » Sun Dec 24, 2017 8:58 am

The Dopefish bug, as you've descreibed it, is well known. For more info, check this page: http://www.shikadi.net/keenwiki/Keen_4_ ... n_God_mode

To solve the loading screen issue, I'll have to have look at your files. You could either send me a link via pm or post things here in the forums. (Please note: I won't answer immediately cause it's Yule...)

Quillax
Posts: 11
Joined: Sun Mar 27, 2016 5:48 pm
Contact:

Re: Couple K4 mod issues

Post by Quillax » Wed Dec 27, 2017 2:04 am

Huh, I didn't know the Dopefish bug was actually possible in the original Keen 4 (or maybe I forgot about it). Anyway, I managed to fix the two problems myself. For the Dopefish problem, I just slightly altered the level structure so now no two Dopefish can be together. For the loading screen problem, I decided to get a fresh copy of TheDraw and followed the tool's instructions with Ceilick's Keen Galaxy Modding Tutorial. After that, the modified loading screen loaded properly. I'm not sure what did I do wrong before doing this, but whatever. I'm glad that I got to fix these problems myself, though.

User avatar
Nisaba
Posts: 226
Joined: Fri Jan 01, 2016 11:15 pm
Location: patch.pat
Contact:

Re: Couple K4 mod issues

Post by Nisaba » Thu Dec 28, 2017 3:40 pm

I'm glad you've managed to fix those things yourself. congrats!
If I may ask: what kind of project are you working on?!

Post Reply